Email notifications to some Microsoft mail servers being rate limited

Incident Report for Studentnet®

Resolved

This incident has been resolved.
Posted Jan 10, 2026 - 08:41 AEDT

Update

We are continuing to investigate this issue.
Posted Jan 10, 2026 - 08:40 AEDT

Update

We are continuing to investigate this issue.
Posted Jan 10, 2026 - 08:39 AEDT

Investigating

We are receiving alerts from Sendgrid that some Microsoft mail receiver servers are rate limiting are attempts to send mail to them. We have commenced a process with Microsoft to lift the rate limit being applied to us. This is only affecting non-commercial Microsoft email addresses and only affecting Microsoft email addresses(eg hotmail.com, live.com, msn.com and outlook.com). Non-commercial Microsoft mail servers are the smallest category of mail servers receiving our email traffic.

Microsoft 365 mail servers are unaffected as are all other mail services(gmail etc).

We estimate that this is affecting about 10% of our mail delivery sends.
Posted Jan 09, 2026 - 07:22 AEDT
This incident affected: Identity Management (Studentnet AuthentID MFA).